Alternativtext
XpressNet USB Interface  

Es gibt für das Lenzsystem zwei (!) Selbstbauprojekte, einmal eines für die RS232-Schnittstelle und kompatibel zum LI100F und eines für die USB-Schnittstelle. Das Interface für den USB-Anschluss wurde von Ronny Gabler in einem Forum vorgestellt, hier kann man sich nach dem Anmelden bis auf die Stückliste alle benötigten Dateien Downloaden.

Installation

Für die Inbetriebnahme des Interface wird das Konfigurationsprogramm und der mitgelieferte Treiber benötigt, wobei für die Installation unter Windows auch eine Inf-Datei in dem Zip Archiv enthalten ist.

Nach dem Anschließen des Interface an einen USB-Anschluss meldet sich Windows nach kurzer Zeit mit der Meldung, dass ein neues Gerät gefunden wurde und fragt, wo und wie es nach einem Treiber suchen soll, die Suche im Internet kann übersprungen, und der Treiber direkt angegeben werden.

Hier ist die Inf-Datei aus dem Zip Archiv anzugeben, und der Hinweis, dass der Treiber nicht von Microsoft zertifiziert wurde, zu bestätigen (Installation fortsetzen). Jetzt sollte die Meldung kommen, dass das neue Gerät erfolgreich installiert wurde und verwendet werden kann.

Unter "Start" - "Systemsteuerung" - "System" - "Hardware" - "Gerätemanager" muss bei "Anschlüsse (COM und LPT)" das Interface mit "USB <-> Serial Interface (COMX)" zu finden sein, wobei das X für den COM-Port steht über den das Interface angesprochen wird:

Über das Konfigurationsprogramm wird der COM-Port (siehe oben) eingestellt und mit der Auswahl automatisch gespeichert (die beiden Schaltflächen beziehen sich ausschließlich auf die Konfiguration der XpressNet-Adresse). Die XpressNet-Adresse sollte sich nun durch einen Klick auf "Lesen" bestimmen, und bei Bedarf über "Schreiben" ändern lassen.
Funktioniert es nicht, gibt es, ausgehend von der Annahme, dass das Interface selber funktioniert, mehrere Möglichkeiten bzw. Ursachen:

Mögliche Fehlerquellen

Funktioniert es nicht, gibt es, ausgehend von der Annahme, dass das Interface selber funktioniert, mehrere Möglichkeiten bzw. Ursachen:

  1. Das Interface wird mit einem Ausrufezeichen im Gerätemanager angezeigt

    Interface deinstallieren und Überprüfen, ob die Windowsinstallation auf dem neusten Stand ist. Erst alle Updates installieren, dann das Interface.

  2. Das Interface wird im Gerätemanager korrekt angezeigt, das Auslesen der XpressNet-Adresse funktioniert trotzdem nicht.

    Manchmal ist Windows etwas eigensinnig und täuscht nur vor, dass es den mitgelieferten Treiber installiert, benutzt dann aber einen eigenen. Die Datei usbser.sys aus dem Zip-Archiv per Hand in das Verzeichnis windows/system32/drivers/ kopieren.

Ggf. hilft es, den eingestellten COM-Port zu ändern: Sollte er zu hoch sein, scheint es öfters Probleme zu geben (ein Problem, welches anscheinend auch bei dem original USB-Interface von Lenz auftritt). Das Menü zum ändern findet sich unter Unter "Start" - "Systemsteuerung" - "System" - "Hardware" - "Eigenschaften von USB <-> Serial Interface" - Anschlusseinstellungen" - "Erweitert"

Testumgebung

Die hier vorliegende Anleitung bezieht sich auf das Interface mit der Firmware 1.1 und einem Laptop mit Windows XP sowie der Testversion von Traincontroller 5.8. Betrieben wird das Interface an einer LZ100 von Lenz (Firmware 3.5), Informationen über den problemlosen Einsatz zusammen mit einer LZV100 und einem Multimaus-System liegen ebenfalls vor.